Commit 63bc1cfe authored by Lars Bilke's avatar Lars Bilke Committed by Dmitry Yu. Naumov
Browse files

[CMake] Added MSVC compiler check (minimum: 19.24).

parent 2aafc2f5
......@@ -110,6 +110,11 @@ if(COMPILER_IS_GCC OR COMPILER_IS_CLANG OR COMPILER_IS_INTEL)
endif()
if(MSVC)
if(${CMAKE_CXX_COMPILER_VERSION} VERSION_LESS ${ogs.minimum_version.msvc.compiler})
message(FATAL_ERROR "Aborting: Visual Studio compiler \
${ogs.minimum_version.msvc.compiler} is required. Found version \
${CMAKE_CXX_COMPILER_VERSION}.")
endif()
if(${MSVC_TOOLSET_VERSION} LESS ${ogs.minimum_version.msvc.toolset})
message(FATAL_ERROR "Aborting: Visual Studio ${ogs.minimum_version.msvc.year} \
is required! Found Visual Studio with toolset version \
......
......@@ -6,7 +6,8 @@
"msvc": {
"year": "2019",
"number": "16",
"toolset": "142"
"toolset": "142",
"compiler": "19.24"
},
"conan": "1.21.0",
"git": "2.14",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment