diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 24ff90cc5cac5ae126bde7931af5cd75ee8dd823..f2b4d95b95a331f17a30efafad67d43919d62d52 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -95,7 +95,6 @@ (define* (autoconf-wrapper #:optional (autoconf autoconf))
 only be used internally---users should not end up distributing `configure'
 files with a system-specific shebang."
   (package (inherit autoconf)
-    (location (source-properties->location (current-source-location)))
     (name (string-append (package-name autoconf) "-wrapper"))
     (build-system trivial-build-system)
     (inputs `(("guile"
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9611ff2620e7f870fcd555b7838935c2025b3dc9..a5402f05569d1752b46390204b40dbeec2c99486 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -65,7 +65,6 @@ (define gnu-make-boot0
   (package-with-bootstrap-guile
    (package (inherit gnu-make)
      (name "make-boot0")
-     (location (source-properties->location (current-source-location)))
      (arguments
       `(#:guile ,%bootstrap-guile
         #:implicit-inputs? #f
@@ -93,7 +92,6 @@ (define diffutils-boot0
                                             ,@%bootstrap-inputs)
                                           #:guile %bootstrap-guile)))
      (package (inherit p)
-       (location (source-properties->location (current-source-location)))
        (arguments `(#:tests? #f         ; the test suite needs diffutils
                     ,@(package-arguments p)))))))
 
@@ -531,7 +529,6 @@ (define-public gcc-final
   ;; The final GCC.
   (package (inherit gcc-boot0)
     (name "gcc")
-    (location (source-properties->location (current-source-location)))
     (arguments
      `(#:guile ,%bootstrap-guile
        #:implicit-inputs? #f
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 9a459400e85668c63af9c7b256dc4431a94a18b2..f1aca505d87cac730156d763ab2535c0f22bd257 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -38,7 +38,6 @@ (define-module (gnu packages cross-base)
 
 (define (cross p target)
   (package (inherit p)
-    (location (source-properties->location (current-source-location)))
     (name (string-append (package-name p) "-cross-" target))
     (arguments
      (substitute-keyword-arguments (package-arguments p)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fbddff1cf62854e28009a106c3a2d055452217a6..0f71c77bf29526dc8b1f7bfd5652bc5f8d36cd91 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -123,7 +123,6 @@ (define-public emacs-no-x
   ;; This is the version that you should use as an input to packages that just
   ;; need to byte-compile .el files.
   (package (inherit emacs)
-    (location (source-properties->location (current-source-location)))
     (name "emacs-no-x")
     (synopsis "The extensible, customizable, self-documenting text
 editor (console only)")
@@ -138,7 +137,6 @@ (define-public emacs-no-x
 
 (define-public emacs-no-x-toolkit
   (package (inherit emacs)
-    (location (source-properties->location (current-source-location)))
     (name "emacs-no-x-toolkit")
     (synopsis "The extensible, customizable, self-documenting text
 editor (without an X toolkit)" )
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 88fad0e6046a6bceb4552565d04f244d7b84e421..7f1b6d50b015d7ff608a499415912ded242d1bc0 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -605,7 +605,6 @@ (define %guile-static-stripped
 (define (tarball-package pkg)
   "Return a package containing a tarball of PKG."
   (package (inherit pkg)
-    (location (source-properties->location (current-source-location)))
     (name (string-append (package-name pkg) "-tarball"))
     (build-system trivial-build-system)
     (native-inputs `(("tar" ,tar)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4d837c85e298b7297abfbd5af97d4f9101d915bb..6fbe6fd27d882a76f1cb460980ce199b354596f6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -560,7 +560,6 @@ (define-public petsc
 
 (define-public petsc-complex
   (package (inherit petsc)
-    (location (source-properties->location (current-source-location)))
     (name "petsc-complex")
     (arguments
      (substitute-keyword-arguments (package-arguments petsc)
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index da664e542214e30408c9c99b0419e38a4baf1d85..05b6e6f680ff5b4023dd8457e495d649656122e6 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -160,12 +160,10 @@ (define (static-libgcc-package p)
   "A version of P linked with `-static-gcc'."
   (package-with-extra-configure-variable p "LDFLAGS" "-static-libgcc"))
 
-(define* (static-package p #:optional (loc (current-source-location))
-                         #:key (strip-all? #t))
+(define* (static-package p #:key (strip-all? #t))
   "Return a statically-linked version of package P.  If STRIP-ALL? is true,
 use `--strip-all' as the arguments to `strip'."
   (package (inherit p)
-    (location (source-properties->location loc))
     (arguments
      (let ((a (default-keyword-arguments (package-arguments p)
                 '(#:configure-flags '()
diff --git a/guix/packages.scm b/guix/packages.scm
index c955b351554ac3bca0671cc78ca7664870fff4f8..c900541e53f91a7751f2561fec82aaee96b93a3d 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -240,7 +240,8 @@ (define-record-type* <package>
 
   (location package-location
             (default (and=> (current-source-location)
-                            source-properties->location))))
+                            source-properties->location))
+            (innate)))
 
 (set-record-type-printer! <package>
                           (lambda (package port)