diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 42b9c758dbff98aee3b04926168d1ffb6ecb884a..f3cb23a564543ff621802110f4ad39450352e796 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -85,7 +85,7 @@ (define-public gegl
               (method url-fetch)
               (uri (list (string-append "https://download.gimp.org/pub/gegl/"
                                         (string-take version 3)
-                                        "/" name "-" version ".tar.bz2")))
+                                        "/gegl-" version ".tar.bz2")))
               (sha256
                (base32
                 "0ljqxc4iyy2hrj31pxcy1xp4xm5zbx1nigqisphmg4p8mcz2jrz9"))))