diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c57c6c670064e0f1a056e98c7d7cbe87ea0dd39c..e7fbd6720a4dcf30544c3eb07332029fc8635de3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -97,7 +97,7 @@ (define-public aalib
      '(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-                  (lambda* (#:key inputs outputs #:allow-other-keys)
+                  (lambda* (#:key build inputs outputs #:allow-other-keys)
                     ;; This old `configure' script doesn't support
                     ;; variables passed as arguments.
                     (let ((out     (assoc-ref outputs "out"))
@@ -105,6 +105,7 @@ (define-public aalib
                       (setenv "CONFIG_SHELL" (which "bash"))
                       (zero? (system* "./configure"
                                       (string-append "--prefix=" out)
+                                      (string-append "--build=" build)
                                       (string-append "--with-ncurses="
                                                      ncurses)))))))))
     (home-page "http://aa-project.sourceforge.net/aalib/")