From 014cbde612f89bc9101e6932f64113415230e9f9 Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Fri, 7 Aug 2015 23:57:08 -0400
Subject: [PATCH] gnu: aalib: Pass --build to configure.

* gnu/packages/video.scm (aalib)[arguments]: In configure phase, accept
  'build' keyword argument and pass it to 'configure'.
---
 gnu/packages/video.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c57c6c67006..e7fbd6720a4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -97,7 +97,7 @@ (define-public aalib
      '(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-                  (lambda* (#:key inputs outputs #:allow-other-keys)
+                  (lambda* (#:key build inputs outputs #:allow-other-keys)
                     ;; This old `configure' script doesn't support
                     ;; variables passed as arguments.
                     (let ((out     (assoc-ref outputs "out"))
@@ -105,6 +105,7 @@ (define-public aalib
                       (setenv "CONFIG_SHELL" (which "bash"))
                       (zero? (system* "./configure"
                                       (string-append "--prefix=" out)
+                                      (string-append "--build=" build)
                                       (string-append "--with-ncurses="
                                                      ncurses)))))))))
     (home-page "http://aa-project.sourceforge.net/aalib/")
-- 
GitLab