diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index dc40974381c10568d18044204d3600f5f77b26d9..1ad6f697a4ca592158b5af568760e1789723a87b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1858,6 +1858,7 @@ (define-public qgis
                              "qgis_filedownloader"
                              ;; TODO: Find why the following tests fail
                              "ProcessingQgisAlgorithmsTestPt1"
+                             "ProcessingQgisAlgorithmsTestPt2"
                              "ProcessingQgisAlgorithmsTestPt3"
                              "ProcessingQgisAlgorithmsTestPt4"
                              "ProcessingGdalAlgorithmsRasterTest"
@@ -1872,6 +1873,7 @@ (define-public qgis
                              "qgis_geometrytest"
                              "qgis_layouthtmltest"
                              "qgis_layoutmaptest"
+                             "qgis_layoutmapgridtest"
                              "qgis_painteffecttest"
                              "qgis_pallabelingtest"
                              "qgis_svgmarkertest"
@@ -1890,6 +1892,11 @@ (define-public qgis
                              "PyQgsFileUtils"
                              "PyQgsGeometryTest"
                              "PyQgsImageCache"
+                             "PyQgsLayerMetadata"
+                             "PyQgsLayout"
+                             "PyQgsLayoutHtml"
+                             "PyQgsLayoutMapGrid"
+                             "PyQgsMetadataBase"
                              "PyQgsLayoutExporter"
                              "PyQgsLayoutLegend"
                              "PyQgsMapLayer"