diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index c2a1801c16c8154e4e473050fba85798e5383928..251520952bdfc832c924ca6263572c4360822218 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -55,8 +55,6 @@ (define-public icecat
        (base32
         "1vxzjwmhad6yxx4sk9zvapjgv5salcv10id061q0991ii3dycy9a"))))
     (build-system gnu-build-system)
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("bzip2" ,bzip2)
@@ -78,8 +76,7 @@ (define-public icecat
      `(("perl" ,perl)
        ("python" ,python-2) ; Python 3 not supported
        ("python2-pysqlite" ,python2-pysqlite)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-2))) ; Python 3 not supported
+       ("pkg-config" ,pkg-config)))
     (arguments
      `(#:tests? #f ; no check target