diff --git a/Makefile.am b/Makefile.am
index 1f257a009c075a41d0cd785eb9a80443096a28dc..5cee3d3b6fac00ac439b81cf3cea8cee5f2ac7fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,7 @@ nodist_noinst_SCRIPTS =				\
   pre-inst-env					\
   test-env
 
-include gnu-system.am
+include gnu/local.mk
 
 MODULES =					\
   guix/base32.scm				\
@@ -416,11 +416,11 @@ install-data-hook: set-bootstrap-executable-permissions
 SUBDIRS = po/guix po/packages
 BUILT_SOURCES =
 
-include doc.am
+include doc/local.mk
 
 if BUILD_DAEMON
 
-include daemon.am
+include nix/local.mk
 
 endif BUILD_DAEMON
 
@@ -437,7 +437,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS =			\
 
 dist_emacsui_DATA = emacs/guix-main.scm
 nodist_emacsui_DATA = emacs/guix-helper.scm
-include emacs.am
+include emacs/local.mk
 
 # The self-contained tarball.
 guix-binary.%.tar.xz:
diff --git a/doc/guix.texi b/doc/guix.texi
index 859db2be12e3329f1d63e317127bc3686f244bea..ab07d1066e1a4a6e493ccd2599829add28d801c6 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -11286,7 +11286,7 @@ to be updated to refer to these binaries on the target platform.  That
 is, the hashes and URLs of the bootstrap tarballs for the new platform
 must be added alongside those of the currently supported platforms.  The
 bootstrap Guile tarball is treated specially: it is expected to be
-available locally, and @file{gnu-system.am} has rules do download it for
+available locally, and @file{gnu/local.mk} has rules do download it for
 the supported architectures; a rule for the new platform must be added
 as well.
 
diff --git a/doc.am b/doc/local.mk
similarity index 100%
rename from doc.am
rename to doc/local.mk
diff --git a/emacs/guix-config.el.in b/emacs/guix-config.el.in
index bd821596c4e970a3465d358518def0dd0280ca0d..d03df9ce6322e5fe0217341c957a796129cc6dc3 100644
--- a/emacs/guix-config.el.in
+++ b/emacs/guix-config.el.in
@@ -24,7 +24,7 @@
   (replace-regexp-in-string "${prefix}" "@prefix@" "@emacsuidir@"))
 
 (defconst guix-config-state-directory
-  ;; This must match `NIX_STATE_DIR' as defined in `daemon.am'.
+  ;; This must match `NIX_STATE_DIR' as defined in `nix/local.mk'.
   (or (getenv "NIX_STATE_DIR") "@guix_localstatedir@/guix"))
 
 (defconst guix-config-guile-program "@GUILE@"
diff --git a/emacs.am b/emacs/local.mk
similarity index 100%
rename from emacs.am
rename to emacs/local.mk
diff --git a/gnu-system.am b/gnu/local.mk
similarity index 100%
rename from gnu-system.am
rename to gnu/local.mk
diff --git a/guix/config.scm.in b/guix/config.scm.in
index 764e466bc52712ae95c96b87c163d62b21de383d..d7df9f7d2bf23b3ec2a45ba1aa3a8d833fcdb1de 100644
--- a/guix/config.scm.in
+++ b/guix/config.scm.in
@@ -55,11 +55,11 @@ (define %store-directory
       "@storedir@"))
 
 (define %state-directory
-  ;; This must match `NIX_STATE_DIR' as defined in `daemon.am'.
+  ;; This must match `NIX_STATE_DIR' as defined in `nix/local.mk'.
   (or (getenv "NIX_STATE_DIR") "@guix_localstatedir@/guix"))
 
 (define %config-directory
-  ;; This must match `NIX_CONF_DIR' as defined in `daemon.am'.
+  ;; This must match `NIX_CONF_DIR' as defined in `nix/local.mk'.
   (or (getenv "NIX_CONF_DIR") "@guix_sysconfdir@/guix"))
 
 (define %guix-register-program
diff --git a/daemon.am b/nix/local.mk
similarity index 100%
rename from daemon.am
rename to nix/local.mk