From 0405e5f49133171602ea9749f5d9fb6bcdcf2669 Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Mon, 20 Jun 2016 23:54:20 -0500
Subject: [PATCH] gnu: Add thefuck.

* gnu/packages/admin.scm (thefuck): New variable.
---
 gnu/packages/admin.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 78f36a18cf4..415a35aab3e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1681,3 +1681,30 @@ (define-public dstat
 throughput (in the same interval).")
     (home-page "http://dag.wiee.rs/home-made/dstat/")
     (license license:gpl2+)))
+
+(define-public thefuck
+  (package
+    (name "thefuck")
+    (version "3.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/nvbn/thefuck/archive/"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0g4s2vkpl0mqhkdkbzib07qr4xf0cq25fvhdhna52290qgd69pwf"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-decorator" ,python-decorator)
+       ("python-psutil" ,python-psutil)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/nvbn/thefuck")
+    (synopsis "Correct mistyped console command")
+    (description
+     "The Fuck tries to match a rule for a previous, mistyped command, creates
+a new command using the matched rule, and runs it.")
+    (license license:x11)))
-- 
GitLab