From 044176621e80eaf7c97cf92a5ea6cf97bd7dd45a Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Mon, 7 Dec 2015 12:31:56 +0200
Subject: [PATCH] gnu: python2-zope-security: Use python2-zope-testrunner.

* gnu/packages/python.scm (python2-zope-security): Do it.
---
 gnu/packages/python.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 056775ec400..d01c1d3df1e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6345,7 +6345,13 @@ (define-public python-zope-security
     (license zpl2.1)))
 
 (define-public python2-zope-security
-  (package-with-python2 python-zope-security))
+  (let ((zope-security (package-with-python2 python-zope-security)))
+    (package (inherit zope-security)
+      (propagated-inputs
+       `(("python2-zope-testrunner" ,python2-zope-testrunner)
+         ,@(alist-delete
+            "python-zope-testrunner"
+            (package-propagated-inputs zope-security)))))))
 
 (define-public python-zope-component
   (package
-- 
GitLab