diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index eb298c8d7a3d0382e13c129601cc22d19a9b89fe..4d9487afa233f6792a297b0f49bfd55cd2dfc227 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1149,8 +1149,7 @@ (define-public ocaml-zarith
        #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key #:allow-other-keys)
-             (zero? (system* "./configure")))))))
+           (lambda _ (invoke "./configure"))))))
     (home-page "https://forge.ocamlcore.org/projects/zarith/")
     (synopsis "Implements arbitrary-precision integers")
     (description "Implements arithmetic and logical operations over