diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 313c6251c6eb1625099381d23dd8c971fe930db1..f9ad95118b9b9e8af22d95973352985c68b331e3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1714,11 +1714,12 @@ (define-public python-testrepository
         (base32
          "1ssqb07c277010i6gzzkbdd46gd9mrj0bi0i8vn560n2k2y4j93m"))))
     (build-system python-build-system)
+    (propagated-inputs
+     `(("python-fixtures" ,python-fixtures)
+       ("python-testtools" ,python-testtools)))
     (inputs
      `(("python-setuptools" ,python-setuptools)
-       ("python-testtools" ,python-testtools)
        ("python-subunit" ,python-subunit)
-       ("python-fixtures" ,python-fixtures)
        ("python-mimeparse" ,python-mimeparse)))
     (home-page "https://launchpad.net/testrepository")
     (synopsis "Database for Python test results")