diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 95d005a6f69a084a32664d2af63e57705075fb9c..0dd3b37b3cf9c2e7e59b1c94db0b2c8fdc60dafd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -349,8 +349,13 @@ (define-public at-spi2-core
              (base32
               "1l3l39mw23zyjlcqidvkyqlr4gwbhplzw2hcv3qvn6p8ikxpf2qw"))))
    (build-system gnu-build-system)
+   (outputs '("out" "doc"))
    (arguments
     '(#:make-flags '("CC=gcc") ; for g-ir-scanner
+      #:configure-flags
+      (list (string-append "--with-html-dir="
+                           (assoc-ref %outputs "doc")
+                           "/share/gtk-doc/html"))
       #:phases
       (modify-phases %standard-phases
         (replace check