diff --git a/gnu/installer.scm b/gnu/installer.scm
index 75c5a0157029a5abbb470b8402d84ceb9040e601..6cd3995e512a84dcb43b3fbab70f6668240a2b4b 100644
--- a/gnu/installer.scm
+++ b/gnu/installer.scm
@@ -198,11 +198,11 @@ (define (installer-steps)
         (timezone-data #~(string-append #$tzdata
                                         "/share/zoneinfo/zone.tab")))
     #~(lambda (current-installer)
-        ((installer-help-menu current-installer)
+        ((installer-parameters-menu current-installer)
          (lambda ()
-           ((installer-help-page current-installer)
+           ((installer-parameters-page current-installer)
             (lambda _
-              (#$(compute-keymap-step 'help)
+              (#$(compute-keymap-step 'param)
                current-installer)))))
         (list
          ;; Ask the user to choose a locale among those supported by
diff --git a/gnu/installer/newt.scm b/gnu/installer/newt.scm
index 7ac015eaadbea0be098cae94f76bc4bcdd5a6eff..a24a152984bbdaa901b53108692626eb57688195 100644
--- a/gnu/installer/newt.scm
+++ b/gnu/installer/newt.scm
@@ -21,7 +21,7 @@ (define-module (gnu installer newt)
   #:use-module (gnu installer utils)
   #:use-module (gnu installer newt ethernet)
   #:use-module (gnu installer newt final)
-  #:use-module (gnu installer newt help)
+  #:use-module (gnu installer newt parameters)
   #:use-module (gnu installer newt hostname)
   #:use-module (gnu installer newt keymap)
   #:use-module (gnu installer newt locale)
@@ -47,7 +47,7 @@ (define (init)
   (clear-screen)
   (set-screen-size!)
   (push-help-line
-   (format #f (G_ "Press <F1> for help."))))
+   (format #f (G_ "Press <F1> for installation parameters."))))
 
 (define (exit)
   (newt-finish)
@@ -112,11 +112,11 @@ (define (partition-page)
 (define (services-page)
   (run-services-page))
 
-(define (help-menu menu-proc)
+(define (parameters-menu menu-proc)
   (newt-set-help-callback menu-proc))
 
-(define (help-page keyboard-layout-selection)
-  (run-help-page keyboard-layout-selection))
+(define (parameters-page keyboard-layout-selection)
+  (run-parameters-page keyboard-layout-selection))
 
 (define newt-installer
   (installer
@@ -135,5 +135,5 @@ (define newt-installer
    (partition-page partition-page)
    (services-page services-page)
    (welcome-page welcome-page)
-   (help-menu help-menu)
-   (help-page help-page)))
+   (parameters-menu parameters-menu)
+   (parameters-page parameters-page)))
diff --git a/gnu/installer/newt/keymap.scm b/gnu/installer/newt/keymap.scm
index 0147a0b9d5879c4f0e438021ab8ffa8f5da8cbd5..8625afaa0361c631d9f30444da9145c0f35e67fc 100644
--- a/gnu/installer/newt/keymap.scm
+++ b/gnu/installer/newt/keymap.scm
@@ -39,21 +39,21 @@ (define (run-layout-page layouts layout->text context)
      #:title title
      #:info-text
      (case context
-       ((help) (G_ "Please choose your keyboard layout. \
+       ((param) (G_ "Please choose your keyboard layout. \
 It will only be used during the installation process."))
        (else (G_ "Please choose your keyboard layout. \
 It will be used during the install process, and for the installed system. \
-You can switch to different layout at any time from the help menu.")))
+You can switch to different layout at any time from the parameters menu.")))
      #:listbox-items layouts
      #:listbox-item->text layout->text
      #:sort-listbox-items? #f
      #:button-text
      (case context
-       ((help) (G_ "Continue"))
+       ((param) (G_ "Continue"))
        (else (G_ "Exit")))
      #:button-callback-procedure
      (case context
-       ((help) (const #t))
+       ((param) (const #t))
        (else
         (lambda _
           (raise
diff --git a/gnu/installer/newt/help.scm b/gnu/installer/newt/parameters.scm
similarity index 75%
rename from gnu/installer/newt/help.scm
rename to gnu/installer/newt/parameters.scm
index a488f5fa2aa5be5fb13f2423c9220f9cede9de1c..4a34e941552bf199b08146120ecdf30b711fbd5b 100644
--- a/gnu/installer/newt/help.scm
+++ b/gnu/installer/newt/parameters.scm
@@ -16,28 +16,29 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (gnu installer newt help)
+(define-module (gnu installer newt parameters)
   #:use-module (gnu installer steps)
   #:use-module (gnu installer newt page)
   #:use-module (guix i18n)
   #:use-module (ice-9 match)
   #:use-module (newt)
-  #:export (run-help-page))
+  #:export (run-parameters-page))
 
-(define (run-help-page keyboard-layout-selection)
-  "Run a help page allowing to change the keyboard layout"
+(define (run-parameters-page keyboard-layout-selection)
+  "Run a parameters page allowing to change the keyboard layout"
   (let* ((items
           (list
            (cons (G_ "Change keyboard layout") keyboard-layout-selection)))
          (result
           (run-listbox-selection-page
-           #:info-text (G_ "This is the help menu, please choose an action.")
-           #:title (G_ "Installation help")
+           #:info-text (G_ "Please choose one of the following parameters or \
+press ‘Back’ to go back to the installation process.")
+           #:title (G_ "Installation parameters")
            #:listbox-items items
            #:listbox-item->text car
            #:sort-listbox-items? #f
            #:listbox-height 6
-           #:button-text (G_ "Continue"))))
+           #:button-text (G_ "Back"))))
     (match result
       ((_ . proc)
        (proc))
diff --git a/gnu/installer/record.scm b/gnu/installer/record.scm
index 78acf50c636987ce42764d89e4656f69b312d710..7bc22e90e02004ba8d9e81ffc8714fe09e0f4323 100644
--- a/gnu/installer/record.scm
+++ b/gnu/installer/record.scm
@@ -38,8 +38,8 @@ (define-module (gnu installer record)
             installer-partition-page
             installer-services-page
             installer-welcome-page
-            installer-help-menu
-            installer-help-page))
+            installer-parameters-menu
+            installer-parameters-page))
 
 
 ;;;
@@ -85,6 +85,6 @@ (define-record-type* <installer>
   ;; procedure (logo) -> void
   (welcome-page installer-welcome-page)
   ;; procedure (menu-proc) -> void
-  (help-menu installer-help-menu)
+  (parameters-menu installer-parameters-menu)
   ;; procedure (keyboard-layout-selection) -> void
-  (help-page installer-help-page))
+  (parameters-page installer-parameters-page))
diff --git a/gnu/local.mk b/gnu/local.mk
index d177faf1069b0b74949497c0b26576d795f8e288..3757f7d6e19362da566115fcaa02b5a98b9f51c5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -672,7 +672,7 @@ INSTALLER_MODULES =                             \
 						\
   %D%/installer/newt/ethernet.scm		\
   %D%/installer/newt/final.scm  		\
-  %D%/installer/newt/help.scm			\
+  %D%/installer/newt/parameters.scm		\
   %D%/installer/newt/hostname.scm		\
   %D%/installer/newt/keymap.scm			\
   %D%/installer/newt/locale.scm			\
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index 4cc4fe7b317cb979f72fd6894d44bed86c159052..77332e7b17ae1456c37b27d909b1483df5bd04d4 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -16,7 +16,7 @@ gnu/installer/locale.scm
 gnu/installer/newt.scm
 gnu/installer/newt/ethernet.scm
 gnu/installer/newt/final.scm
-gnu/installer/newt/help.scm
+gnu/installer/newt/parameters.scm
 gnu/installer/newt/hostname.scm
 gnu/installer/newt/keymap.scm
 gnu/installer/newt/locale.scm