diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 8c4369dbd8cad120a31c4f284f18f94c50882842..3c69fd98586d1c79d667afb8a9920cdcc6179906 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -80,7 +80,7 @@ (define-module (gnu packages dns)
 (define-public dnsmasq
   (package
     (name "dnsmasq")
-    (version "2.81")
+    (version "2.82")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -88,7 +88,7 @@ (define-public dnsmasq
                     version ".tar.xz"))
               (sha256
                (base32
-                "1yzq6anwgr5rlnwydpszb51cyhp2vjq29b24ck19flbwac1sk73l"))))
+                "0cn1xd1s6xs78jmrmwjnh9m6w3q38pk6dyqy2phvasqiyd33cll4"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))