From 07f7cc03cead55543f2df6d6e954010e8c6c1357 Mon Sep 17 00:00:00 2001
From: Alex Kost <alezost@gmail.com>
Date: Fri, 22 Jul 2016 11:10:35 +0300
Subject: [PATCH] gnu: Add guile-daemon.

* gnu/packages/guile.scm (guile-daemon): New variable.
---
 gnu/packages/guile.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9b850162212..acae23eceaf 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1154,4 +1154,29 @@ (define-public guile-xosd
 library}.")
     (license gpl3+)))
 
+(define-public guile-daemon
+  (package
+    (name "guile-daemon")
+    (version "0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/alezost/" name
+                                  "/releases/download/v" version
+                                  "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1s90h8qhblhhz4ahn3p5d573a24px6cdjq2w311ibpgwnsni4qvq"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("guile" ,guile-2.0)))
+    (home-page "https://github.com/alezost/guile-daemon")
+    (synopsis "Evaluate code in a running Guile process")
+    (description
+     "Guile-Daemon is a small Guile program that loads your initial
+configuration file, and then reads and evaluates Guile expressions that
+you send to a FIFO file.")
+    (license gpl3+)))
+
 ;;; guile.scm ends here
-- 
GitLab