From 089b06348e8129980660c69f8122015c1ad6ae9c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Sat, 25 May 2013 18:03:52 +0200
Subject: [PATCH] gnu: libffi: Allow cross-compilation.

* gnu/packages/libffi.scm (libffi): Use %standard-cross-phases as the
  base when cross-compiling.  Add (guix build gnu-cross-build) to the
  #:modules when cross-compiling.  Improve synopsis.
---
 gnu/packages/libffi.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index 21ddd463409..f7d4a8c908a 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -49,11 +49,16 @@ (define out (assoc-ref outputs "out"))
                "0ln4jbpb6clcsdpb9niqk0frgx4k0xki96wiv067ig0q4cajb7aq"))))
     (build-system gnu-build-system)
     (arguments `(#:modules ((guix build utils) (guix build gnu-build-system)
-                            (ice-9 ftw) (srfi srfi-26))
+                            (ice-9 ftw) (srfi srfi-26)
+                            ,@(if (%current-target-system)
+                                  '((guix build gnu-cross-build))
+                                  '()))
                  #:phases (alist-cons-after 'install 'post-install
                                             ,post-install-phase
-                                            %standard-phases)))
-    (synopsis "libffi, a foreign function call interface library")
+                                            ,(if (%current-target-system)
+                                                 '%standard-cross-phases
+                                                 '%standard-phases))))
+    (synopsis "Foreign function call interface library")
     (description
      "The libffi library provides a portable, high level programming interface
 to various calling conventions.  This allows a programmer to call any
-- 
GitLab