diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 3c6db64ad786d7e14fc2863d8c556c24cff0f528..3df98737810dbd16b698c67ef3f640692e672d60 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -452,14 +452,14 @@ (define-public badvpn
 (define-public wireguard
   (package
     (name "wireguard")
-    (version "0.0.20190702")
+    (version "0.0.20190905")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://git.zx2c4.com/WireGuard/snapshot/"
                                   "WireGuard-" version ".tar.xz"))
               (sha256
                (base32
-                "1b5s1ncwqxdgb0c6cd07x4ynnj6cpbiqp4bxqir7mm5bf6y124qs"))))
+                "1xm8w773impgp11jj6kp3fghld0aj8nhfpqla6lflsr8npp7qxkq"))))
     (build-system gnu-build-system)
     (outputs '("out" ; The WireGuard userspace tools
                "kernel-patch")) ; A patch to build Linux with WireGuard support