diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bbc053129ef4f4e1214cc98b502531b6ec9509e2..1bcf49fb705940b60d8e8bad1c8ae12b1b85438f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -189,7 +189,7 @@ (define (lookup file)
      #f)))
 
 (define-public linux-libre
-  (let* ((version "3.15.8")
+  (let* ((version "3.15.9")
          (build-phase
           '(lambda* (#:key system inputs #:allow-other-keys #:rest args)
              ;; Apply the neat patch.
@@ -262,7 +262,7 @@ (define-public linux-libre
              (uri (linux-libre-urls version))
              (sha256
               (base32
-               "1ichq7b08rrfq61i8kpan9vxw9mxcfpcl8cw0a6lbc1ycwzvm7xw"))))
+               "0q1dipb7ivv83nxrhhllpvs3g2mv7z4s2xdxxrzxaw86ryh0nn1y"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)
                      ("bc" ,bc)