From 0bc6ef2a87eb6501fb5925a1569a7c17a072f843 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sun, 30 Oct 2016 18:32:11 -0400
Subject: [PATCH] gnu: Add python-pytest-2.9.2.

* gnu/packages/python.scm (python-pytest-2.9.2): New variable.
---
 gnu/packages/python.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5df774fd100..f971bb0cfcb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1665,6 +1665,31 @@ (define-public python-pytest
 (define-public python2-pytest
   (package-with-python2 python-pytest))
 
+;; This package is used by Borg until we can upgrade all our Python packages to
+;; use a more recent pytest.
+(define-public python-pytest-2.9.2
+  (package
+    (inherit python-pytest)
+    (name "python-pytest")
+    (version "2.9.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pytest" version))
+              (sha256
+               (base32
+                "1n6igbc1b138wx1q5gca4pqw1j6nsyicfxds5n0b5989kaxqmh8j"))))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'disable-invalid-test
+           (lambda _
+             (substitute* "testing/test_argcomplete.py"
+               (("def test_remove_dir_prefix" line)
+                (string-append "@pytest.mark.skip"
+                               "(reason=\"Assumes that /usr exists.\")\n    "
+                               line)))
+             #t)))))))
+
 (define-public python-pytest-cov
   (package
     (name "python-pytest-cov")
-- 
GitLab