From 0d697202fcb53ac819c2fc8b103b7837e7db4c10 Mon Sep 17 00:00:00 2001
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Thu, 10 May 2018 01:04:46 +0200
Subject: [PATCH] gnu: android-selinux: Simplify.

* gnu/packages/android.scm (android-selinux)[arguments]<#:phases>[unpack-core]: Delete.
[native-inputs]: Remove "core".
---
 gnu/packages/android.scm | 7 -------
 1 file changed, 7 deletions(-)

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 7e4f402c9c3..bae5b77ffea 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -435,12 +435,6 @@ (define-public android-libselinux
                           "LDFLAGS=-L . -lpcre")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'unpack-core
-           (lambda* (#:key inputs #:allow-other-keys)
-             (mkdir-p "core")
-             (with-directory-excursion "core"
-               (invoke "tar" "axf" (assoc-ref inputs "core") "--strip-components=1"))
-             #t))
          (add-after 'unpack-core 'patch-HOST
            (lambda _
              ;; gettid duplicates otherwise.
@@ -451,7 +445,6 @@ (define-public android-libselinux
      `(("openssl" ,openssl)))
     (native-inputs
      `(("android-bionic-uapi" ,android-bionic-uapi)
-       ("core" ,(android-platform-system-core version))
        ;; pcre is inlined by our package.
        ("pcre" ,pcre)))
     (home-page "https://developer.android.com/")
-- 
GitLab