From 0f0c586a076208be53eff3c70f8ce42bca17a614 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
Date: Sun, 30 Aug 2015 21:17:43 +0800
Subject: [PATCH] gnu: Add xfce4-pulseaudio-plugin.

* gnu/packages/xfce.scm (xfce4-pulseaudio-plugin): New variable.
---
 gnu/packages/xfce.scm | 34 +++++++++++++++++++++++++++++++++-
 1 file changed, 33 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bc6d47a92a0..bdb52358806 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -38,7 +38,8 @@ (define-module (gnu packages xfce)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages photo)
-  #:use-module (gnu packages pcre))
+  #:use-module (gnu packages pcre)
+  #:use-module (gnu packages pulseaudio))
 
 (define-public gtk-xfce-engine
   (package
@@ -352,6 +353,37 @@ (define-public xfce4-clipman-plugin
 matching them against regular expressions.")
     (license (list gpl2+))))
 
+(define-public xfce4-pulseaudio-plugin
+  (package
+    (name "xfce4-pulseaudio-plugin")
+    (version "0.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  name "/" (version-major+minor version) "/"
+                                  name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0crvb2gyxbnlf46712arg3m2vqx81dixqhqdwss0bngpijy3ca78"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("exo" ,exo)
+       ("libnotify" ,libnotify)
+       ("libxfce4ui" ,libxfce4ui)
+       ("pulseaudio" ,pulseaudio)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page "http://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/")
+    (synopsis "PulseAudio panel plugin for Xfce")
+    (description
+     "Xfce PulseAudio plugin is a plugin for the Xfce panel which provides a
+convenient way to adjust the audio volume of the PulseAudio sound system and
+to an auto mixer tool like pavucontrol.  It can optionally handle multimedia
+keys for controlling the audio volume.")
+    (license gpl2+)))
+
 (define-public xfce4-appfinder
   (package
     (name "xfce4-appfinder")
-- 
GitLab