From 0faddfc392a62c4b5b4e68487d1835ab1aeab858 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Tue, 5 Dec 2017 18:45:19 +0100
Subject: [PATCH] gnu: ghc-aws: Update to 0.18.

* gnu/packages/haskell.scm (ghc-aws): Update to 0.18.
[inputs]: Replace ghc-cryptohash with ghc-cryptonite.
---
 gnu/packages/haskell.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 66ccbae7f44..4d1aabff0b8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7985,14 +7985,14 @@ (define-public ghc-conduit-combinators
 (define-public ghc-aws
   (package
     (name "ghc-aws")
-    (version "0.17.1")
+    (version "0.18")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://hackage.haskell.org/package/"
                            "aws-" version "/aws-" version ".tar.gz"))
        (sha256 (base32
-                "1q4qh58vj8447a4fl88n3nkpdc4yv293qsh02w6zvszd6ch61yh7"))))
+                "0h7473wkvc5xjzx5fd5k5fp70rjq5gqmn1cpy95mswvvfsq3irxj"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f)) ; Tests require AWS credentials.
     (inputs
@@ -8006,7 +8006,7 @@ (define-public ghc-aws
        ("ghc-cereal" ,ghc-cereal)
        ("ghc-conduit" ,ghc-conduit)
        ("ghc-conduit-extra" ,ghc-conduit-extra)
-       ("ghc-cryptohash" ,ghc-cryptohash)
+       ("ghc-cryptonite" ,ghc-cryptonite)
        ("ghc-data-default" ,ghc-data-default)
        ("ghc-http-conduit" ,ghc-http-conduit)
        ("ghc-http-types" ,ghc-http-types)
-- 
GitLab