diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 9a58776fb84a1dd88c447544a5c7d5071b89564e..078e0c57a30da1969d15a958a3291e4ef1850be9 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -75,7 +75,7 @@ (define-public grep
    (build-system gnu-build-system)
    (synopsis "Print lines matching a pattern")
    (description
-    "Grep is a tool for finding text inside files.  Text is found by
+     "grep is a tool for finding text inside files.  Text is found by
 matching a pattern provided by the user in one or many files.  The pattern
 may be provided as a basic or extended regular expression, or as fixed
 strings.  By default, the matching text is simply printed to the screen,
diff --git a/gnu/packages/gperf.scm b/gnu/packages/gperf.scm
index 9e2e3c6ec43ac3a6bcdaeb5645a6a85efa5e015d..9d9aaba3ce24c0ec799b8491c1ab3e77a832e8a5 100644
--- a/gnu/packages/gperf.scm
+++ b/gnu/packages/gperf.scm
@@ -39,7 +39,7 @@ (define-public gperf
     (home-page "http://www.gnu.org/software/gperf/")
     (synopsis "Perfect hash function generator")
     (description
-     "GNU gperf is a perfect hash function generator.  For a given list of
+     "gperf is a perfect hash function generator.  For a given list of
 strings, it produces a hash function and hash table in C or C++ code.  That
 the hash function is perfect means that no collisions can exist and that
 look-ups can be made by single string comparisons.")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 2ae982d10e731be404e455be92d9099b2c442853..edc65d599e11f78de2deaa648ec28c2d2192110d 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -262,7 +262,7 @@ (define-public guile-ncurses
     (home-page "http://www.gnu.org/software/guile-ncurses/")
     (synopsis "Guile bindings to ncurses")
     (description
-     "GNU Guile-Ncurses provides Guile language bindings for the ncurses
+     "guile-ncurses provides Guile language bindings for the ncurses
 library.")
     (license lgpl3+)))
 
diff --git a/gnu/packages/libidn.scm b/gnu/packages/libidn.scm
index 02e15e50fbb9df3cab4741b825c3b4f3265f61fc..3e55618e5326133644b81534e6a1cc27cccb0e20 100644
--- a/gnu/packages/libidn.scm
+++ b/gnu/packages/libidn.scm
@@ -37,7 +37,7 @@ (define-public libidn
 ;; FIXME: No Java and C# libraries are currently built.
    (synopsis "Internationalized string processing library")
    (description
-    "GNU Libidn is a library implementing of the Stringprep, Punycode and IDNA
+     "libidn is a library implementing of the Stringprep, Punycode and IDNA
 specifications.  These are used to encode and decode internationalized domain
 names.  It includes native C, C# and Java libraries.")
    (license lgpl2.1+)
diff --git a/gnu/packages/miscfiles.scm b/gnu/packages/miscfiles.scm
index e9ee8ad42e2ee7fee1d9310712edf83b20df7667..fd0fc7b8e28ef70be0a26e1f4c44a8526988df94 100644
--- a/gnu/packages/miscfiles.scm
+++ b/gnu/packages/miscfiles.scm
@@ -36,9 +36,12 @@ (define-public miscfiles
         "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
     (build-system gnu-build-system)
     (home-page "https://www.gnu.org/software/miscfiles/")
-    (synopsis "Collection of miscellaneous text files")
-    (description "Miscfiles is a collection of files not of crucial importance
-for system administration or operation, but which have come to be common on
-various systems over the years. It includes data files for country codes,
-airport codes, currency information, and so on.")
+    (synopsis
+     "Data files for airport codes, zip codes, a dictionary, and more")
+    (description
+     "GNU Miscfiles is a collection of common data files.  They include, for
+example, country abbreviations, names and capital cities; currency
+abbreviations and names; a Best Current Practices index; a map of the ASCII
+character set; a list of three-letter airport codes; and an English word
+list.")
     (license gpl2+)))
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 4f2193ce478eb3521a9c507c5fdb98eff6904ff9..a5a7902f9cc28e50c328ddc16e01cb9a21e7a196 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -44,7 +44,7 @@ (define-public commoncpp
             (("^// TODO sc.*") "#include <sys/types.h>\n#include <sys/stat.h>\n")))
         %standard-phases)))
    (build-system gnu-build-system)
-   (synopsis "Common C++ framework for threaded applications")
+   (synopsis "(u)Common C++ framework for threaded applications")
    (description "GNU Common C++ is an portable, optimized class framework for
 threaded applications, supporting concurrent synchronization, inter-process
 communications via sockets, and various methods for data handling, such as