diff --git a/Makefile.am b/Makefile.am
index ada4cbea0bd43efbc0c3d13ee492c59fd3cdedde..76d505abf5b4b67c6020c36e6b334556debfac31 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,7 +88,6 @@ MODULES =					\
   guix/build/rpath.scm				\
   guix/build/cvs.scm				\
   guix/build/svn.scm				\
-  guix/build/syscalls.scm			\
   guix/build/gremlin.scm			\
   guix/build/emacs-utils.scm			\
   guix/build/graft.scm				\
@@ -124,6 +123,13 @@ MODULES =					\
   guix.scm					\
   $(GNU_SYSTEM_MODULES)
 
+if BUILD_SYSCALLS_MODULE
+
+MODULES +=					\
+  guix/build/syscalls.scm
+
+endif
+
 if BUILD_DAEMON_OFFLOAD
 
 MODULES +=					\
@@ -298,6 +304,13 @@ EXTRA_DIST +=					\
 
 endif !BUILD_DAEMON_OFFLOAD
 
+if !BUILD_SYSCALLS_MODULE
+
+EXTRA_DIST +=					\
+  guix/build/syscalls.scm
+
+endif !BUILD_SYSCALLS_MODULE
+
 
 CLEANFILES =					\
   $(GOBJECTS)					\
diff --git a/configure.ac b/configure.ac
index 2c8b9f076c153c872631db75c7ab86f8ff0e01b5..247a9d5068207f91137ef28d9d416591cd8cd208 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,11 @@ dnl Check whether (srfi srfi-37) works, and provide our own if it doesn't.
 GUIX_CHECK_SRFI_37
 AM_CONDITIONAL([INSTALL_SRFI_37], [test "x$ac_cv_guix_srfi_37_broken" = xyes])
 
+dnl Check whether (guix build syscalls) can be built.
+GUIX_CHECK_LIBC_MOUNT
+AM_CONDITIONAL([BUILD_SYSCALLS_MODULE],
+  [test "x$guix_cv_libc_has_mount" = "xyes"])
+
 AC_ARG_WITH([nix-prefix],
   [AS_HELP_STRING([--with-nix-prefix=DIR],
     [search for Nix in DIR (for testing purposes and '--disable-daemon' builds)])],
diff --git a/m4/guix.m4 b/m4/guix.m4
index fa5a4023ba02a599a2f6cd57565216c16476de73..21133837700f823ef77902fa9fc0ffc55cd3f1ef 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -257,3 +257,16 @@ AC_DEFUN([GUIX_ASSERT_CXX11], [
     AC_MSG_ERROR([C++ compiler '$CXX' does not support the C++11 standard])
   fi
 ])
+
+dnl GUIX_CHECK_LIBC_MOUNT
+dnl
+dnl Check whether libc provides 'mount'.  On GNU/Hurd it doesn't (yet).
+AC_DEFUN([GUIX_CHECK_LIBC_MOUNT], [
+  AC_CACHE_CHECK([whether libc provides 'mount'], [guix_cv_libc_has_mount],
+    [GUILE_CHECK([retval], [(dynamic-func \"mount\" (dynamic-link))])
+     if test "$retval" = 0; then
+       guix_cv_libc_has_mount="yes"
+     else
+       guix_cv_libc_has_mount="no"
+     fi])
+])