diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 73662cc388cc6c82af6ba4cfd97c44752ca477fa..40df25ef405f1fc084a9f9ab58a50cc77ae0fa4e 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -840,7 +840,7 @@ (define-public python2-stdnum
 (define-public python-duniterpy
   (package
     (name "python-duniterpy")
-    (version "0.43.7")
+    (version "0.50.0")
     (source
      (origin
        (method git-fetch)
@@ -851,10 +851,14 @@ (define-public python-duniterpy
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "19m36z98361bqxjdb65597j2kxbly491927c6p9z47s1vxc3raaq"))))
+         "0f24ihglmzphy30pgc49w0rxmsjc76mgcggg078cfsz7xrrk13gf"))))
     (build-system python-build-system)
+    (arguments
+     ;; Tests fail with "AttributeError: module 'attr' has no attribute 's'".
+     `(#:tests? #f))
     (propagated-inputs
      `(("python-aiohttp" ,python-aiohttp)
+       ("python-attr" ,python-attr)
        ("python-base58" ,python-base58)
        ("python-jsonschema" ,python-jsonschema)
        ("python-libnacl" ,python-libnacl)