From 14d17788a942424fd1825d72b043f1b67e31900b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 11 Apr 2014 21:38:28 +0200
Subject: [PATCH] gnu: Add Protobuf.

* gnu/packages/protobuf.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
---
 gnu-system.am             |  1 +
 gnu/packages/protobuf.scm | 46 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 47 insertions(+)
 create mode 100644 gnu/packages/protobuf.scm

diff --git a/gnu-system.am b/gnu-system.am
index bc12478202a..fb0139c4313 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -181,6 +181,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/pth.scm				\
   gnu/packages/pulseaudio.scm			\
   gnu/packages/pretty-print.scm			\
+  gnu/packages/protobuf.scm			\
   gnu/packages/python.scm			\
   gnu/packages/qemu.scm				\
   gnu/packages/qt.scm				\
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
new file mode 100644
index 00000000000..03d1edcee78
--- /dev/null
+++ b/gnu/packages/protobuf.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages protobuf)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses)
+                #:select (bsd-3))
+  #:use-module (gnu packages compression))
+
+(define-public protobuf
+  (package
+    (name "protobuf")
+    (version "2.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://protobuf.googlecode.com/files/protobuf-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "0xxn9gxhvsgzz2sgmihzf6pf75clr05mqj6218camwrwajpcbgqk"))))
+    (build-system gnu-build-system)
+    (inputs `(("zlib" ,zlib)))
+    (home-page "http://code.google.com/p/protobuf/")
+    (synopsis "Data encoding for remote procedure calls (RPCs)")
+    (description
+     "Protocol Buffers are a way of encoding structured data in an efficient
+yet extensible format.  Google uses Protocol Buffers for almost all of its
+internal RPC protocols and file formats.")
+    (license bsd-3)))
-- 
GitLab