diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d2216e927b187a66b62e35abde482d3f3fd58f6e..ddc31a9e89e88042cf751e157887e06922f19f11 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -426,8 +426,8 @@ (define* (make-linux-libre version hash supported-systems
 It has been modified to remove all non-free binary blobs.")
     (license license:gpl2)))
 
-(define %linux-libre-version "5.1")
-(define %linux-libre-hash "153vd48k98pm8556hfnvs9za77n91gwv0dvv5hnzzhwl9l6jxbcl")
+(define %linux-libre-version "5.1.1")
+(define %linux-libre-hash "1pcx9nilvx4rklaiy0vpfvk5rp5i54arfysybgrlasjmghva2nf8")
 
 (define %linux-libre-5.1-patches
   (list %boot-logo-patch