diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a82cde7d0ad5d142fda1588cd7cef885e2829df0..dac58b939d8a5582766febb7e506fb2275754af4 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -681,7 +681,7 @@ (define xmlsec-src-libreoffice
 (define-public libreoffice
   (package
     (name "libreoffice")
-    (version "5.0.3.2")
+    (version "5.0.5.2")
     (source
      (origin
       (method url-fetch)
@@ -690,7 +690,7 @@ (define-public libreoffice
           "http://download.documentfoundation.org/libreoffice/src/"
           (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
       (sha256 (base32
-               "1gflcsnw7bx02jbb2x5darf56x0qgia03ylaycadk68ikibckybp"))))
+               "120vcxpxzs0za76fyfry281ysv6d1ianb37d1yq8py8chkdjkrqy"))))
     (build-system gnu-build-system)
     (native-inputs
      `(;; autoreconf is run by the LibreOffice build system, since after