From 186de634a79c94d4524f477675c67ae533caeb55 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Tue, 18 Nov 2014 13:55:47 +0100
Subject: [PATCH] gnu: curl: Enable more verbose test output.

* gnu/packages/curl.scm (curl)[arguments]: Fold 'patch-runtests' phase
  into 'check' phase, and replace the standard 'check' phase.  Run "make
  -C tests test".
---
 gnu/packages/curl.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 1a428d54ffc..f595e7259c2 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -61,11 +61,16 @@ (define-public curl
     `(#:configure-flags '("--with-gnutls" "--with-gssapi")
       ;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
       #:phases
-      (alist-cons-before
-       'check 'patch-runtests
+      (alist-replace
+       'check
        (lambda _
-           (substitute* "tests/runtests.pl"
-             (("/bin/sh") (which "sh"))))
+         (substitute* "tests/runtests.pl"
+           (("/bin/sh") (which "sh")))
+
+         ;; The top-level "make check" does "make -C tests quiet-test", which
+         ;; is too quiet.  Use the "test" target instead, which is more
+         ;; verbose.
+         (zero? (system* "make" "-C" "tests" "test")))
        %standard-phases)))
    (synopsis "Command line tool for transferring data with URL syntax")
    (description
-- 
GitLab