From 18ef998bfc91da5fd27e524e5e4b05f6374cf73a Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Mon, 11 Jan 2016 19:38:11 +0100
Subject: [PATCH] gnu: bristol: Remove SSE flags on platforms other than x86_64
 and i686.

* gnu/packages/music.scm (bristol)[arguments]: Add phase
"remove-sse-flags" to remove unsupported optimizations on platforms
other than x86_64 and i686.
---
 gnu/packages/music.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c54920986df..813893e11b1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -659,6 +659,16 @@ (define-public bristol
                (base32
                 "1fi2m4gmvxdi260821y09lxsimq82yv4k5bbgk3kyc3x1nyhn7vx"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'remove-sse-flags
+           (lambda* (#:key system #:allow-other-keys)
+             (when (not (or (string-prefix? "x86_64" system)
+                            (string-prefix? "i686" system)))
+               (substitute* "bristol/Makefile.in"
+                 (("-msse -mfpmath=sse") "")))
+             #t)))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("jack" ,jack-1)
-- 
GitLab