From 1bc275034fe8070c720ca341db2d9588480aa044 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Mon, 10 Aug 2020 12:40:49 -0400
Subject: [PATCH] gnu: Use a descriptive file-name for linux-libre deblobbing
 scripts.

Fixes <https://bugs.gnu.org/42789>.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Set the file-name of the
deblob and deblob-check scripts.
---
 gnu/packages/linux.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index afe8d2ade51..1ad38a63c40 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -194,12 +194,16 @@ (define (linux-libre-deblob-scripts version
           (uri (string-append "https://linux-libre.fsfla.org"
                               "/pub/linux-libre/releases/" version "-gnu/"
                               "deblob-" (version-major+minor version)))
+          (file-name (string-append "linux-libre-deblob-"
+                                    (version-major+minor version)))
           (sha256 deblob-hash))
         (origin
           (method url-fetch)
           (uri (string-append "https://linux-libre.fsfla.org"
                               "/pub/linux-libre/releases/" version "-gnu/"
                               "deblob-check"))
+          (file-name (string-append "linux-libre-deblob-check-"
+                                    (version-major+minor version)))
           (sha256 deblob-check-hash))))
 
 (define deblob-scripts-5.8
-- 
GitLab