From 1c4b3512db48a34aa5e7993167aa70a3124cdf34 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Tue, 1 Sep 2020 04:43:34 +0200
Subject: [PATCH] gnu: editorconfig-core-c: Delete static library.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/text-editors.scm (editorconfig-core-c)[arguments]: Add a
‘delete-static-library’ phase.
---
 gnu/packages/text-editors.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index e0f07832f2e..5b7f2e937c8 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -727,7 +727,14 @@ (define-public editorconfig-core-c
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((tests (assoc-ref inputs "tests")))
                (copy-recursively tests "tests"))
-             #t)))))
+             #t))
+         (add-after 'install 'delete-static-library
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib")))
+               (with-directory-excursion lib
+                 (delete-file "libeditorconfig_static.a"))
+               #t))))))
     (native-inputs
      `(("tests"
         ,(origin
-- 
GitLab