From 1e44cf8b0ffe88f2675718c0a0f5119c87a8bf6a Mon Sep 17 00:00:00 2001
From: Ben Woodcroft <b.woodcroft@uq.edu.au>
Date: Tue, 9 Jun 2015 16:10:51 +0200
Subject: [PATCH] gnu: Add OrfM.

* gnu/packages/bioinformatics.scm (orfm): New variable.

Signed-off-by: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
---
 gnu/packages/bioinformatics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index df627fbe48b..7175ecf41db 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1101,6 +1101,27 @@ (define-public miso
 that a read originated from a particular isoform.")
     (license license:gpl2)))
 
+(define-public orfm
+  (package
+    (name "orfm")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/wwood/OrfM/releases/download/v"
+                    version "/orfm-" version ".tar.gz"))
+              (sha256
+               (base32
+                "00jqvlspj9662ni9r4n1snxfnwkzc02i46g5nk1kwjshi6v3vgg3"))))
+    (build-system gnu-build-system)
+    (inputs `(("zlib" ,zlib)))
+    (synopsis "Simple and not slow open reading frame (ORF) caller")
+    (description
+     "An ORF caller finds stretches of DNA that when translated are not
+interrupted by stop codons.  OrfM finds and prints these ORFs.")
+    (home-page "https://github.com/wwood/OrfM")
+    (license license:lgpl3+)))
+
 (define-public python2-pbcore
   (package
     (name "python2-pbcore")
-- 
GitLab