diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index df65c7515486da818ac480f671a461c2c6cf393f..32cdc2b53a64d1d757f7358b9708def2683abb12 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -259,8 +259,8 @@ (define-public libgeotiff
        ("proj" ,proj)))
     (arguments
      `(#:configure-flags
-       (list (string-append "--with-zlib")
-             (string-append "--with-jpeg")
+       (list "--disable-static"
+             "--with-zlib" "--with-jpeg"
              (string-append "--with-libtiff=" (assoc-ref %build-inputs "libtiff")))))
     (synopsis "Library for handling GeoTIFF (geographic enabled TIFF)")
     (description "libgeotiff is a library on top of libtiff for reading and