From 20c05ea94af8f55821ffe203d9f0d97ab0e0748f Mon Sep 17 00:00:00 2001
From: David Thompson <dthompson2@worcester.edu>
Date: Sat, 29 Aug 2015 22:08:20 -0400
Subject: [PATCH] gnu: Make ruby-diff-lcs a public package.

* gnu/packages/ruby.scm (ruby-diff-lcs-for-rspec): Rename this...
  (ruby-diff-lcs): ... to this, and export it.
  (ruby-rspec-expectation, ruby-rspec-mocks): Use new varaible.
---
 gnu/packages/ruby.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0e45e063055..561fe4d9860 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -254,7 +254,7 @@ (define-public ruby-rspec-core
     (home-page "https://github.com/rspec/rspec-core")
     (license license:expat)))
 
-(define ruby-diff-lcs-for-rspec
+(define-public ruby-diff-lcs
   (package
     (name "ruby-diff-lcs")
     (version "1.2.5")
@@ -290,7 +290,7 @@ (define-public ruby-rspec-expectations
      '(#:tests? #f)) ; avoid dependency cycles
     (propagated-inputs
      `(("ruby-rspec-support" ,ruby-rspec-support)
-       ("ruby-diff-lcs" ,ruby-diff-lcs-for-rspec)))
+       ("ruby-diff-lcs" ,ruby-diff-lcs)))
     (synopsis "RSpec expectations library")
     (description "Rspec-expectations provides a simple API to express expected
 outcomes of a code example.")
@@ -312,7 +312,7 @@ (define-public ruby-rspec-mocks
      '(#:tests? #f)) ; avoid dependency cycles
     (propagated-inputs
      `(("ruby-rspec-support" ,ruby-rspec-support)
-       ("ruby-diff-lcs" ,ruby-diff-lcs-for-rspec)))
+       ("ruby-diff-lcs" ,ruby-diff-lcs)))
     (synopsis "RSpec stubbing and mocking library")
     (description "Rspec-mocks provides RSpec's \"test double\" framework, with
 support for stubbing and mocking.")
-- 
GitLab