diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3cabb9f528a56d985790b3ec75d83b9e1076a853..314d0ad32293e7e61ddc58c62b0f55a64ae6874a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2456,18 +2456,21 @@ (define-public samtools-0.1
        (sha256
         (base32 "1m33xsfwz0s8qi45lylagfllqg7fphf4dr0780rsvw75av9wk06h"))))
     (arguments
-     (substitute-keyword-arguments (package-arguments samtools)
-       ((#:tests? tests) #f) ;no "check" target
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (replace 'install
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((bin (string-append
-                                  (assoc-ref outputs "out") "/bin")))
-                        (mkdir-p bin)
-                        (copy-file "samtools"
-                                   (string-append bin "/samtools")))))
-           (delete 'patch-tests)))))))
+     `(#:tests? #f ;no "check" target
+       ,@(substitute-keyword-arguments (package-arguments samtools)
+           ((#:make-flags flags)
+            `(cons "LIBCURSES=-lncurses" ,flags))
+           ((#:phases phases)
+            `(modify-phases ,phases
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let ((bin (string-append
+                               (assoc-ref outputs "out") "/bin")))
+                     (mkdir-p bin)
+                     (copy-file "samtools"
+                                (string-append bin "/samtools")))))
+               (delete 'patch-tests)
+               (delete 'configure))))))))
 
 (define-public mosaik
   (let ((commit "5c25216d"))