From 248d08ebf0f2333d13c36358a4e1556c7114048b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 24 May 2013 21:54:44 +0200
Subject: [PATCH] gnu: cross-gcc: Change patch so that `CROSS_LIBRARY_PATH' is
 honored.

* gnu/packages/patches/gcc-cross-environment-variables.patch: Add two
  hunks, most notably one that changes GCC to honor LIBRARY_PATH_ENV
  when cross-compiling.
---
 .../gcc-cross-environment-variables.patch     | 24 +++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/patches/gcc-cross-environment-variables.patch b/gnu/packages/patches/gcc-cross-environment-variables.patch
index 30a07ec3dbf..0bd0be59840 100644
--- a/gnu/packages/patches/gcc-cross-environment-variables.patch
+++ b/gnu/packages/patches/gcc-cross-environment-variables.patch
@@ -22,3 +22,27 @@ at <http://gcc.gnu.org/ml/gcc/2013-02/msg00124.html>.
 +#define LIBRARY_PATH_ENV "CROSS_LIBRARY_PATH"
 +
  #endif /* ! GCC_SYSTEM_H */
+
+--- gcc-4.7.2/gcc/tlink.c	2012-02-11 09:50:23.000000000 +0100
++++ gcc-4.7.2/gcc/tlink.c	2013-05-23 22:06:19.000000000 +0200
+@@ -461,7 +461,7 @@ recompile_files (void)
+   file *f;
+ 
+   putenv (xstrdup ("COMPILER_PATH="));
+-  putenv (xstrdup ("LIBRARY_PATH="));
++  putenv (xstrdup (LIBRARY_PATH_ENV "="));
+ 
+   while ((f = file_pop ()) != NULL)
+     {
+
+--- gcc-4.7.3/gcc/gcc.c	2013-03-08 08:25:09.000000000 +0100
++++ gcc-4.7.3/gcc/gcc.c	2013-05-24 08:58:16.000000000 +0200
+@@ -3726,7 +3726,7 @@ process_command (unsigned int decoded_op
+     }
+ 
+   temp = getenv (LIBRARY_PATH_ENV);
+-  if (temp && *cross_compile == '0')
++  if (temp)
+     {
+       const char *startp, *endp;
+       char *nstore = (char *) alloca (strlen (temp) + 3);
-- 
GitLab