From 2534fc04781aa1bbeb5b3a36cbf9bfa169616a2d Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Mon, 4 May 2015 22:27:32 +0200
Subject: [PATCH] gnu: Add libwpg.

* gnu/packages/libreoffice.scm (libwpg): New variable.
---
 gnu/packages/libreoffice.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 32d1792ce2e..a832710255c 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -28,6 +28,7 @@ (define-module (gnu packages libreoffice)
   #:use-module (gnu packages doxygen)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages xml))
@@ -139,7 +140,6 @@ (define-public libwpd
 into other word processors.")
     (license '(mpl2.0 lgpl2.1+)))) ; dually licensed
 
-
 (define-public libe-book
   (package
     (name "libe-book")
@@ -173,3 +173,29 @@ (define-public libe-book
 cellphones), TCR (simple compressed text format), TealDoc, zTXT,
 ZVR (simple compressed text format).")
     (license mpl2.0)))
+
+(define-public libwpg
+  (package
+    (name "libwpg")
+    (version "0.3.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
+                          version ".tar.xz"))
+      (sha256 (base32
+               "097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("doxygen" ,doxygen)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("librevenge" ,librevenge)
+       ("libwpd" ,libwpd)
+       ("perl" ,perl)
+       ("zlib" ,zlib)))
+    (home-page "http://libwpg.sourceforge.net/")
+    (synopsis "Library and tools for the WordPerfect Graphics format")
+    (description "The libwpg project provides a library and tools for
+working with graphics in the WPG (WordPerfect Graphics) format.")
+    (license '(mpl2.0 lgpl2.1+)))) ; dually licensed
-- 
GitLab