From 2597e47d9ef8bb868e341f6d1c01b76d81a9ae6b Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Thu, 23 Jul 2020 09:50:43 +0200
Subject: [PATCH] gnu: khal: Fix a failing test.

* gnu/packages/calendar.scm (khal)[arguments]: Fix a failing test.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
---
 gnu/packages/calendar.scm | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 726687d4887..53c73c969d7 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com
 ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -195,6 +196,12 @@ (define-public khal
              "doc/build/man/khal.1"
              (string-append (assoc-ref outputs "out") "/share/man/man1"))
             #t))
+        (add-before 'check 'fix-tests
+          (lambda _
+            ;; Reported upstream: <https://github.com/pimutils/khal/issues/947>.
+            (substitute* "tests/cli_test.py"
+             (("Invalid value for \"\\[ICS\\]\"") "Invalid value for \\'[ICS]\\'"))
+            #t))
         (replace 'check
           (lambda* (#:key inputs #:allow-other-keys)
             ;; The tests require us to choose a timezone.
-- 
GitLab