diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cd36ebfd6509ffa78ef947da915e6a109f0ec924..cd54cfc5b99a163043f5f83fcf73604dde2425a9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -505,7 +505,12 @@ (define-public gtk+
       ("python-wrapper" ,python-wrapper)
       ("xorg-server" ,xorg-server)))
    (arguments
-    `(#:phases
+    `(;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
+      ;; to "doc".
+      #:configure-flags (list (string-append "--with-html-dir="
+                                             (assoc-ref %outputs "doc")
+                                             "/share/gtk-doc/html"))
+      #:phases
       (alist-cons-before
        'configure 'pre-configure
        (lambda _