diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 22256f750b669917157c976b5017ce1a8d8903dd..daefbd01bd4acd3de24c5d708afb57e13132fc73 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -404,8 +404,12 @@ (define* (aspell-word-list language synopsis
                              (find-files "speller"
                                          ,(string-append language ".*\\.dic$"))))
 
-               (install-file ,(string-append "speller/" language ".aff")
-                             hunspell)
+               ;; Install affix files corresponding to installed dictionaries
+               (for-each (lambda (dic)
+                           (install-file (string-append
+                                           "speller/" (basename dic ".dic") ".aff")
+                                         hunspell))
+                         (find-files hunspell ".*\\.dic$"))
                (symlink hunspell (string-append myspell "/dicts"))
                (for-each (lambda (file)
                            (install-file file doc))