From 2b14c60d3870e74f620775ec8dd64634ff874dc7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 8 Nov 2019 17:52:54 +0100
Subject: [PATCH] gnu: rdma-core: Use the "write" ioctl mode.

* gnu/packages/linux.scm (rdma-core)[arguments]: Add "-DIOCTL_MODE=write"
to #:configure-flags.
---
 gnu/packages/linux.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index dd3640e6a87..92c9e7fca33 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4322,7 +4322,14 @@ (define-public rdma-core
        ;; to do the same for consistency. They also recommend using the
        ;; "Release" build type.
        #:build-type "Release"
-       #:configure-flags (list "-GNinja")
+       #:configure-flags (list "-GNinja"
+
+                               ;; On some configurations, the
+                               ;; IB_USER_MAD_REGISTER_AGENT ioctl, which is
+                               ;; used by default, would return ENODEV.  To
+                               ;; avoid that, use 'write' instead of ioctls,
+                               ;; as suggested in 'CMakeList.txt'.
+                               "-DIOCTL_MODE=write")
        #:phases
        (modify-phases %standard-phases
          (replace 'build
-- 
GitLab