From 2c6b6d7991e978369f577d3021a46c3b973fb850 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Tue, 1 Sep 2020 18:30:57 +0200
Subject: [PATCH] gnu: libopenmpt: Remove 5.1-MiB static library.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/audio.scm (libopenmpt)[arguments]: Add a
‘delete-static-libraries’ phase.
---
 gnu/packages/audio.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bd9071e7b66..9447156e0e2 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -311,7 +311,15 @@ (define-public libopenmpt
     (arguments
      `(#:configure-flags
        (list (string-append "--docdir=" (assoc-ref %outputs "out")
-                            "/share/doc/" ,name "-" ,version))))
+                            "/share/doc/" ,name "-" ,version))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'delete-static-libraries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib")))
+               (for-each delete-file (find-files lib "\\.a$"))
+               #t))))))
     (native-inputs
      `(("doxygen" ,doxygen)
        ("perl" ,perl)
-- 
GitLab