From 2c880ef4e542c0d6aead79f740e140e45f47a855 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Thu, 7 Feb 2019 22:05:19 -0600
Subject: [PATCH] gnu: Add python-rope.

* gnu/packages/python-xyz.scm (python-rope): New variable.

Co-authored-by: Brett Gilio <brettg@posteo.net>
---
 gnu/packages/python-xyz.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac22a69d803..0ba9f5266df 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8859,6 +8859,16 @@ (define-public python2-rope
 to occurrences in strings and comments.")
     (license license:gpl2)))
 
+(define-public python-rope
+  (package
+    (inherit python2-rope)
+    (name "python-rope")
+    (arguments `(#:python ,python-wrapper
+                 ;; XXX: Only partial python3 support, results in some failing
+                 ;; tests: <https://github.com/python-rope/rope/issues/247>.
+                 #:tests? #f))
+    (properties `((python2-variant . ,(delay python2-rope))))))
+
 (define-public python-py3status
   (package
     (name "python-py3status")
-- 
GitLab