diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index e9c213cbb2cd93f748f1f3f8f1cd723ad2d13504..6971e792d0a190ee37950bbd832cd0bb19d8d3d3 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -43,6 +43,22 @@ (define-public skribilo
      '(#:configure-flags (list (string-append "--with-guilemoduledir="
                                               (assoc-ref %outputs "out")
                                               "/share/guile/site/2.0"))
+
+       #:phases (alist-cons-before
+                 'configure 'pre-configure
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Make sure the 'skribilo' command gets to see
+                   ;; Guile-Reader, even if Guile-Reader is not in the search
+                   ;; path.
+                   (let ((reader (assoc-ref inputs "guile-reader")))
+                     (substitute* "src/skribilo.in"
+                       (("^exec (.*) -c" _ things)
+                        (string-append "exec " things
+                                       " -L " reader "/share/guile/site/2.0"
+                                       " -C " reader "/share/guile/site/2.0"
+                                       " -c")))))
+                 %standard-phases)
+
        #:parallel-build? #f))
     ;; TODO: Add Ploticus.
     (inputs `(("guile" ,guile-2.0)