From 2f7a10db6d9507cf0b4f7a965e13c59ea682ad68 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Thu, 18 Sep 2014 11:22:01 +0200
Subject: [PATCH] gnu: skribilo: Make sure Guile-Reader is in the search path.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Reported by Luis Souto Graña <luissoutobueu@gmail.com>.

* gnu/packages/skribilo.scm (skribilo)[arguments]: Add #:phases.
---
 gnu/packages/skribilo.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index e9c213cbb2c..6971e792d0a 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -43,6 +43,22 @@ (define-public skribilo
      '(#:configure-flags (list (string-append "--with-guilemoduledir="
                                               (assoc-ref %outputs "out")
                                               "/share/guile/site/2.0"))
+
+       #:phases (alist-cons-before
+                 'configure 'pre-configure
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   ;; Make sure the 'skribilo' command gets to see
+                   ;; Guile-Reader, even if Guile-Reader is not in the search
+                   ;; path.
+                   (let ((reader (assoc-ref inputs "guile-reader")))
+                     (substitute* "src/skribilo.in"
+                       (("^exec (.*) -c" _ things)
+                        (string-append "exec " things
+                                       " -L " reader "/share/guile/site/2.0"
+                                       " -C " reader "/share/guile/site/2.0"
+                                       " -c")))))
+                 %standard-phases)
+
        #:parallel-build? #f))
     ;; TODO: Add Ploticus.
     (inputs `(("guile" ,guile-2.0)
-- 
GitLab