diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 381777fd0e7bee2e16fada597e152bf5ae0899dd..069aae6d0175b4d54c30e042f6714eda40b1d530 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -192,7 +192,7 @@ (define (lookup file)
      #f)))
 
 (define-public linux-libre
-  (let* ((version "3.17.2")
+  (let* ((version "3.17.3")
          (build-phase
           '(lambda* (#:key system inputs #:allow-other-keys #:rest args)
              ;; Apply the neat patch.
@@ -265,7 +265,7 @@ (define-public linux-libre
              (uri (linux-libre-urls version))
              (sha256
               (base32
-               "14npqjr82aldiw1y2hl175pppj6m7vxf672m3gb6wj9hykhydwzr"))))
+               "1qyk70m7y7ak94idkqpgyinnnpqpwxvl39rwh8pqdvrcm7w5b0lq"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)
                      ("bc" ,bc)