diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 403b70852b03c2236fef8fc419e195b73c5fa0eb..e5d7b19262d1acfa47dabdcde16e514e303e1eda 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -92,7 +92,7 @@ (define-public mate-themes
 (define-public mate-desktop
   (package
     (name "mate-desktop")
-    (version "1.16.1")
+    (version "1.18.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://pub.mate-desktop.org/releases/"
@@ -100,11 +100,8 @@ (define-public mate-desktop
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1pzncfgrzp2mp9407ivk1113hkadpf110blr058h31jkwsk8syjq"))))
+                "12iv2y4dan962fs7vkkxbjkp77pbvjnwfa43ggr0zkdsc3ydjbbg"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags '("--with-gtk=3.0"
-                           "--enable-mpaste")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
@@ -115,7 +112,6 @@ (define-public mate-desktop
     (inputs
      `(("gtk+" ,gtk+)
        ("libxrandr" ,libxrandr)
-       ("python2" ,python-2)
        ("startup-notification" ,startup-notification)))
     (propagated-inputs
      `(("dconf" ,dconf))) ; mate-desktop-2.0.pc