diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 13223fbb664f81e7306407170448f6e9917522b5..bea52ea480fa04f56e36b03f638d8a2fc28c6552 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -51,7 +51,7 @@ (define-public llvm
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://llvm.org/releases/"
+      (uri (string-append "https://llvm.org/releases/"
                           version "/llvm-" version ".src.tar.xz"))
       (sha256
        (base32
@@ -118,7 +118,7 @@ (define* (clang-runtime-from-llvm llvm hash
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://llvm.org/releases/"
+       (uri (string-append "https://llvm.org/releases/"
                            version "/compiler-rt-" version ".src.tar.xz"))
        (sha256 (base32 hash))
        (patches (map search-patch patches))))
@@ -150,7 +150,7 @@ (define* (clang-from-llvm llvm clang-runtime hash
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://llvm.org/releases/"
+       (uri (string-append "https://llvm.org/releases/"
                            version "/cfe-" version ".src.tar.xz"))
        (sha256 (base32 hash))
        (patches (map search-patch patches))))
@@ -291,7 +291,7 @@ (define-public llvm-3.9.1
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://llvm.org/releases/"
+      (uri (string-append "https://llvm.org/releases/"
                           version "/llvm-" version ".src.tar.xz"))
       (sha256
        (base32
@@ -341,7 +341,7 @@ (define-public llvm-3.7
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://llvm.org/releases/"
+       (uri (string-append "https://llvm.org/releases/"
                            version "/llvm-" version ".src.tar.xz"))
        (sha256
         (base32
@@ -365,7 +365,7 @@ (define-public llvm-3.6
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://llvm.org/releases/"
+       (uri (string-append "https://llvm.org/releases/"
                            version "/llvm-" version ".src.tar.xz"))
        (sha256
         (base32
@@ -388,7 +388,7 @@ (define-public llvm-3.5
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://llvm.org/releases/"
+       (uri (string-append "https://llvm.org/releases/"
                            version "/llvm-" version ".src.tar.xz"))
        (patches
         (search-patches "llvm-3.5-fix-clang-build-with-gcc5.patch"))
@@ -511,7 +511,7 @@ (define-public emacs-clang-format
     (description "This package allows to filter code through @code{clang-format}
 to fix its formatting.  @code{clang-format} is a tool that formats
 C/C++/Obj-C code according to a set of style options, see
-@url{http://clang.llvm.org/docs/ClangFormatStyleOptions.html}.")))
+@url{https://clang.llvm.org/docs/ClangFormatStyleOptions.html}.")))
 
 (define-public emacs-clang-rename
   (package